A foreign security investigation agency pointed out that the PTP communication function and firmware upgrade function used by some Canon digital cameras have security loopholes

A foreign security investigation agency pointed out that the PTP communication function and firmware upgrade function used by some Canon digital cameras have security loopholes

   On August 6, Canon Its official website issued a security announcement. A foreign security investigation agency pointed out that the PTP communication function and firmware upgrade function used by some Canon digital cameras have security loopholes. If the computer or mobile device connected to the camera has been attacked from an insecure network, there is a risk of a third party exploiting these vulnerabilities to attack the camera. At present, no loss has been found due to the above-mentioned vulnerabilities, but in order to ensure that users can use our products with confidence, the following countermeasures are proposed:

Ensure that the device connected to the camera has been properly set up. If the computer or mobile device is connected to an unsecured network environment, do not connect the camera. Do not connect the camera to a computer or mobile device that may be infected with a virus. When not using the camera’s network function, turn it off. When upgrading the camera firmware, please download the official version from the Canon website.

  [Target product]

   Target products are EOS series, PowerShot SX740 HS, PowerShot SX70 HS, PowerShot G5XMark II.

  [Firmware upgrade]

   The number of users using computers and mobile devices in an unconfirmed network environment is increasing. Moreover, it has become the norm to use Wi-Fi connections to transfer images from cameras to mobile devices. Therefore, we will provide firmware upgrades for models with Wi-Fi connectivity. Canon will provide product firmware upgrade information in the order of completion. The list is as follows:

A foreign security investigation agency pointed out that the PTP communication function and firmware upgrade function used by some Canon digital cameras have security loopholes

  ※1 If you use a WiFi adapter or wireless file transfer , You can establish a WiFi connection.

  ※2 Ethernet connections are also affected by these vulnerabilities.

Author:SINA,If you need to reprint,please indicate the source:http://www.todaycamera.com/camera-news/a-foreign-security-investigation-agency-pointed-out-that-the-ptp-communication-function-and-firmware-upgrade-function-used-by-some-canon-digital-cameras-have-security-loopholes